Patrick Rhone

Can’t use Wavelength because I have an iPhone 5 (app requires iOS 11) so no microblog hosted podcasting for me.